blob: 69f38721b187962d6323cfe29e87749d126c3510 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Configuration files for kexecboot"
2DESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader."
3SECTION = "base"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
6
7SRC_URI = "file://icon.xpm"
8
9S = "${WORKDIR}"
10
11do_install_prepend () {
12echo '# /boot/boot.cfg - KEXECBOOT configuration file.
13#
14# First kernel stanza.
15# Show this label in kexecboot menu.
16#
17LABEL=${KEXECBOOT_LABEL}
18#
19# Specify full kernel path on target.
20KERNEL=/boot/${KERNEL_IMAGETYPE}
21#
22# Append this tags to the kernel cmdline.
23APPEND=${CMDLINE} ${CMDLINE_DEBUG}
24#
25# Specify optional initrd/initramfs.
26# INITRD=/boot/initramfs.cpio.gz
27#
28# Specify full path for a custom icon for the menu-item.
29# If not set, use device-icons as default (NAND, SD, CF, ...).
30# ICON=/boot/icon.xpm
31#
32# Priority of item in kexecboot menu.
33# Items with highest priority will be shown at top of menu.
34# Default: 0 (lowest, ordered by device ordering)
35# PRIORITY=10
36#
37#
38# Second kernel stanza.
39# LABEL=${KEXECBOOT_LABEL}-test
40# KERNEL=/boot/${KERNEL_IMAGETYPE}-test
41# APPEND=${CMDLINE}
42#' > ${S}/boot.cfg
43}
44do_install () {
45 install -d ${D}/boot
46 install -m 0644 boot.cfg ${D}/boot/boot.cfg
47 install -m 0644 icon.xpm ${D}/boot/icon.xpm
48}
49
50PACKAGE_ARCH = "${MACHINE_ARCH}"
51
52FILES_${PN} += "/boot/*"
53
54CMDLINE ?= ""
55CMDLINE_DEBUG ?= "quiet"
56
57INHIBIT_DEFAULT_DEPS = "1"
58
59# Note: for qvga the label is currently limited to about 24 chars
60KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO', True) or d.getVar('DISTRO_VERSION', True)}-${MACHINE}"