blob: 45095f31127d5636c94774ef6224b6bcb5157398 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001###########################
2# Configure options:
3#
4# --enable-static-linking compile kexecboot as static executable [default=no]
5# --enable-fbui support framebuffer menu [default=yes]
6# --enable-fbui-width limit FB UI width to specified value [default=no]
7# --enable-fbui-height limit FB UI height to specified value [default=no]
8# --enable-textui support console text user interface [default=no]
9# --enable-cfgfiles support config files [default=yes]
10# --enable-icons support custom icons (depends on fbui) [default=yes]
11# --enable-zaurus compile Sharp Zaurus specific code [default=no]
12# --enable-zimage compile with zImage support [default=yes]
13# --enable-uimage compile with uImage support [default=no]
14# --enable-machine-kernel look for machine-specific zImage kernel [default=no]
15# --enable-devices-recreating
16# enable devices re-creating [default=yes]
17# --enable-debug enable debug output [default=no]
18# --enable-host-debug allow for non-destructive executing of kexecboot on
19# host system [default=no]
20# --enable-numkeys enable menu item selection by keys [0-9] [default=yes]
21# --enable-bg-buffer enable buffer for pre-drawed FB GUI background
22#
23# --enable-timeout allow to boot 1st kernel after timeout in seconds
24# [default=no]
25# --enable-delay specify delay before device scanning, allowing
26# initialization of old CF/SD cards [default=1]
27# --enable-bpp enable support of specified bpp modes
28# (all,32,24,18,16,4,2,1) [default=all]
29# --enable-evdev-rate change evdev (keyboard/mouse) repeat rate
30# in milliseconds e.g. "1000,250" [default=no]
31# --with-kexec-binary look for kexec binary at path
32# [default="/usr/sbin/kexec"]
33##########################
34SUMMARY = "kexecboot linux-as-bootloader"
35DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
36HOMEPAGE = "http://kexecboot.org"
37LICENSE = "GPLv2"
38LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
39
40S = "${WORKDIR}/kexecboot-${PV}"
41SRC_URI = "https://github.com/kexecboot/kexecboot/archive/v${PV}.tar.gz"
42SRC_URI[md5sum] = "46b7c1a6f20531be56445ebb8669a2b8"
43SRC_URI[sha256sum] = "6b360b8aa59bc5d68a96705349a0dd416f8ed704e931fa0ac7849298258f0f15"
44
45SRC_URI += "\
46 file://0001-kexecboot-fix-build-when-S-B.patch \
47 file://0002-kexecboot-fix-configure-warnings.patch \
48 file://0003-kexecboot-do-not-hardcode-MOUNTPOINT.patch \
49 file://0004-kexecboot.c-workaround-for-absolute-kernel-and-initr.patch \
50 \
51 file://0005-rgb.h-fix-build-with-gcc5.patch \
52 "
53
54inherit autotools
55
56EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
57
58do_install () {
59 install -d ${D}${bindir}
60 install -m 0755 kexecboot ${D}${bindir}
61 install -d ${D}/proc
62 install -d ${D}/mnt
63 install -d ${D}/dev
64 install -d ${D}/sys
65}
66
67PACKAGE_ARCH = "${MACHINE_ARCH}"
68
69FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
70
71pkg_postinst_${PN} () {
72 ln -sf ${bindir}/kexecboot $D/init
73}
74
75BBCLASSEXTEND = "klibc"