blob: c9fec25426490453941bb94f29ab2b49c8ff1d4a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# the binaries are statically linked against klibc
2require recipes-kernel/kexec/kexec-tools.inc
3SUMMARY = "Kexec tools, statically compiled against klibc"
4SRC_URI[md5sum] = "92eff93b097475b7767f8c98df84408a"
5SRC_URI[sha256sum] = "09e180ff36dee087182cdc939ba6c6917b6adbb5fc12d589f31fd3659b6471f2"
6
7inherit klibc
8
9FILESPATH =. "${FILE_DIRNAME}/kexec-tools-${PV}:"
10
11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/kexec/kexec-tools-${PV}.tar.gz"
12
13SRC_URI += " \
14 file://kexec-elf-rel.patch \
15 file://kexec-syscall.patch \
16 file://cflags_static.patch \
17 file://ifdown_errno.patch \
18 file://purgatory_flags.patch \
19 file://purgatory_string.patch \
20 file://sha256.patch \
21 file://sysconf_nrprocessors.patch \
22 file://fix-out-of-tree-build.patch \
23 "
24
25SRC_URI_append_arm = " file://arm_crashdump.patch"
26SRC_URI_append_powerpc = " file://ppc__lshrdi3.patch"
27SRC_URI_append_x86 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
28SRC_URI_append_x86-64 = " file://x86_sys_io.patch file://x86_basename.patch file://x86_vfscanf.patch file://x86_kexec_test.patch"
29
30S = "${WORKDIR}/kexec-tools-${PV}"
31
32EXTRA_OECONF += "--without-zlib --without-lzma --without-xen"
33
34CFLAGS += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits32"
35CFLAGS_x86-64 += "-I${STAGING_DIR_HOST}${libdir}/klibc/include -I${STAGING_DIR_HOST}${libdir}/klibc/include/bits64"
36
37PACKAGES =+ "kexec-klibc kdump-klibc"
38
39FILES_kexec-klibc = "${sbindir}/kexec"
40FILES_kdump-klibc = "${sbindir}/kdump"