blob: 54e8697c4e53eb5aab6e39210ecba374da83dbeb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Fluidsynth is a software synthesizer"
2HOMEPAGE = "http://www.fluidsynth.org/"
3SECTION = "libs/multimedia"
4LICENSE = "LGPL-2.0+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e198e9aac94943d0ec29a7dae8c29416"
6
7DEPENDS = "alsa-lib ncurses glib-2.0"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BP}/${BP}.tar.gz"
10SRC_URI[md5sum] = "ae5aca6de824b4173667cbd3a310b263"
11SRC_URI[sha256sum] = "50853391d9ebeda9b4db787efb23f98b1e26b7296dd2bb5d0d96b5bccee2171c"
12
13inherit autotools-brokensep pkgconfig lib_package
14
15PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)}"
16PACKAGECONFIG[sndfile] = "--enable-libsndfile-support,--disable-libsndfile-support,libsndfile1"
17PACKAGECONFIG[jack] = "--enable-jack-support,--disable-jack-support,jack"
18PACKAGECONFIG[pulseaudio] = "--enable-pulse-support,--disable-pulse-support,pulseaudio"
19PACKAGECONFIG[portaudio] = "--enable-portaudio-support,--disable-portaudio-support,portaudio-v19"
20
21do_configure_prepend () {
22 rm -f ${S}/m4/*
23}