blob: 4b73aa354cffec8049dd7c9fe475bf4aee84310e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION="SoX is the Swiss Army knife of sound processing tools. \
2It converts audio files among various standard audio file formats \
3and can apply different effects and filters to the audio data."
4HOMEPAGE = "http://sox.sourceforge.net"
5SECTION = "audio"
6
7DEPENDS = "libpng ffmpeg libsndfile1 libvorbis"
8
9PR = "r2"
10
11PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)} \
13 magic \
14"
15PACKAGECONFIG[pulseaudio] = "--with-pulseaudio=dyn,--with-pulseaudio=no,pulseaudio,"
16PACKAGECONFIG[alsa] = "--with-alsa=dyn,--with-alsa=no,alsa-lib,"
17PACKAGECONFIG[wavpack] = "--with-wavpack=dyn,--with-wavpack=no,wavpack,"
18PACKAGECONFIG[flac] = "--with-flac=dyn,--with-flac=no,flac,"
19PACKAGECONFIG[amrwb] = "--with-amrwb=dyn,--with-amrwb=no,opencore-amr,"
20PACKAGECONFIG[amrnb] = "--with-amrnb=dyn,--with-amrnb=no,opencore-amr,"
21PACKAGECONFIG[magic] = "--with-magic,--without-magic,file,"
22PACKAGECONFIG[mad] = "--with-mad,--without-mad,libmad,"
23PACKAGECONFIG[id3tag] = "--with-id3tag,--without-id3tag,libid3tag,"
24PACKAGECONFIG[lame] = "--with-lame,--without-lame,lame,"
25PACKAGECONFIG[ao] = "--with-ao,--without-ao,libao,"
26
27LICENSE = "GPLv2 & LGPLv2.1"
28LIC_FILES_CHKSUM = "file://LICENSE.GPL;md5=751419260aa954499f7abaabaa882bbe \
29 file://LICENSE.LGPL;md5=fbc093901857fcd118f065f900982c24"
30
31SRC_URI = "${SOURCEFORGE_MIRROR}/sox/sox-${PV}.tar.gz"
32SRC_URI[md5sum] = "b0c15cff7a4ba0ec17fdc74e6a1f9cf1"
33SRC_URI[sha256sum] = "3ee34b14dd267de378e8a117aae81ec4cae330772342e6a55bbf6520a0a88aa3"
34
35inherit autotools
36
37BBCLASSEXTEND = "native"
38