blob: 48039f07ad2403fc6cc741ebcddfacd8ba83628f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The dump DAQ test the various inline mode features "
2HOMEPAGE = "http://www.snort.org"
3SECTION = "libs"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f9ce51a65dd738dc1ae631d8b21c40e0"
6
7PARALLEL_MAKE = ""
8
9DEPENDS = "libpcap libpcre libdnet"
10
11SRC_URI = "http://fossies.org/linux/misc/daq-${PV}.tar.gz \
12 file://disable-run-test-program-while-cross-compiling.patch "
13
14# these 2 create undeclared dependency on libdnet and libnetfilter-queue from meta-networking
15# this error from test-dependencies script:
16# daq/daq/latest lost dependency on libdnet libmnl libnetfilter-queue libnfnetlink
17#
18# never look to /usr/local lib while cross compiling
19
20EXTRA_OECONF = "--disable-nfq-module --disable-ipq-module --includedir=${includedir} \
21 --with-libpcap-includes=${STAGING_INCDIR} --with-dnet-includes=${STAGING_LIBDIR}"
22
23SRC_URI[md5sum] = "2cd6da422a72c129c685fc4bb848c24c"
24SRC_URI[sha256sum] = "b40e1d1273e08aaeaa86e69d4f28d535b7e53bdb3898adf539266b63137be7cb"
25
26inherit autotools