blob: d5c7afe04f756aeddec147b253abf025f53c34a3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Lightweight crypto and SSL/TLS library"
2DESCRIPTION = "mbedtls is a lean open source crypto library \
3for providing SSL and TLS support in your programs. It offers \
4an intuitive API and documented header files, so you can actually \
5understand what the code does. It features: \
6 \
7 - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \
8 Camellia and XTEA \
9 - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \
10 - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \
11 - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \
12 ECDSA and ECDH \
13 - SSL v3 and TLS 1.0, 1.1 and 1.2 \
14 - Abstraction layers for ciphers, hashes, public key operations, \
15 platform abstraction and threading \
16"
17
18HOMEPAGE = "https://polarssl.org"
19BUGTRACKER = "https://github.com/polarssl/polarssl/issues"
20
21LICENSE = "GPLv2"
22LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
23
24SECTION = "libdevel"
25
26SRC_URI = "https://tls.mbed.org/download/mbedtls-${PV}-gpl.tgz"
27
28SRC_URI[md5sum] = "19ebbc96feceb430ad958dfe89cb633f"
29SRC_URI[sha256sum] = "746fd88e0c6623691fc56c4eed52e40a57b2da0ac80f6dd8995094aa6adb407e"
30
31DEPENDS = "openssl"
32RDEPENDS_${PN} += "libcrypto"
33PROVIDES += "polarssl"
34RPROVIDES_${PN} = "polarssl"
35EXTRA_OECMAKE = "-DUSE_SHARED_POLARSSL_LIBRARY=on -DLIB_INSTALL_DIR=${baselib}"
36
37inherit cmake