blob: 09c4007ef82fd5fcd755b6e2aae6f8ee806c7d8a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "VLAN provides vconfig utility"
2SECTION = "misc"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://vconfig.c;md5=293ef69c4e88434d37a5ee577a5288cb"
5
6SRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz \
7 file://no-HOME-includes.patch"
8
9SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394"
10SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca"
11
12S = "${WORKDIR}/${BPN}"
13
14EXTRA_OEMAKE = "-e MAKEFLAGS="
15
16# comment out MakeInclude in Makefile which sets build environment
17do_configure_append () {
18 sed -i 's/^ include/#^include/' ${S}/Makefile
19}
20
21# ignore strip to avoid yocto errors in stripping
22do_compile () {
23 oe_runmake PLATFORM=ARM 'STRIP=echo' all
24}
25
26do_install () {
27 install -d ${D}/${base_sbindir}
28 install -m 0755 ${S}/vconfig ${D}/${base_sbindir}/
29}