blob: 77ed09f542a5e3979b87cd72f1bbe1033da37ba3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A 802.1ab implementation (LLDP) to help you locate neighbors of all your equipments"
2SECTION = "net/misc"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/ISC;md5=f3b90e78ea0cffb20bf5cca7947a896d"
5
6DEPENDS = "libbsd libevent"
7
8SRC_URI = "\
9 http://media.luffy.cx/files/${BPN}/${BPN}-${PV}.tar.gz \
10 file://lldpd.init.d \
11 file://lldpd.default \
12 "
13
14SRC_URI[md5sum] = "b809887bc927fb558fd5dd64b6c0a494"
15SRC_URI[sha256sum] = "6054f29d41faf32186a22331853a299c87f4419b4332df4a564f76a139305a32"
16
17inherit autotools update-rc.d useradd systemd pkgconfig bash-completion
18
19USERADD_PACKAGES = "${PN}"
20USERADD_PARAM_${PN} = "--system -g lldpd --shell /bin/false lldpd"
21GROUPADD_PARAM_${PN} = "--system lldpd"
22
23EXTRA_OECONF += "--without-embedded-libevent \
24 --disable-oldies \
25 --with-privsep-user=lldpd \
26 --with-privsep-group=lldpd \
27 --with-systemdsystemunitdir=${systemd_system_unitdir} \
28 --without-sysusersdir \
29"
30
31PACKAGECONFIG ??= "cdp fdp edp sonmp lldpmed dot1 dot3"
32PACKAGECONFIG[json] = "--with-json,--without-json,jansson"
33PACKAGECONFIG[xml] = "--with-xml,--without-xml,libxm2"
34PACKAGECONFIG[snmp] = "--with-snmp,--without-snmp,net-snmp"
35PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
36PACKAGECONFIG[seccomp] = "--with-seccomp,--without-seccomp,libseccomp"
37PACKAGECONFIG[cdp] = "--enable-cdp,--disable-cdp"
38PACKAGECONFIG[fdp] = "--enable-fdp,--disable-fdp"
39PACKAGECONFIG[edp] = "--enable-edp,--disable-edp"
40PACKAGECONFIG[sonmp] = "--enable-sonmp,--disable-sonmp"
41PACKAGECONFIG[lldpmed] = "--enable-lldpmed,--disable-lldpmed"
42PACKAGECONFIG[dot1] = "--enable-dot1,--disable-dot1"
43PACKAGECONFIG[dot3] = "--enable-dot3,--disable-dot3"
44PACKAGECONFIG[custom] = "--enable-custom,--disable-custom"
45
46INITSCRIPT_NAME = "lldpd"
47INITSCRIPT_PARAMS = "defaults"
48
49SYSTEMD_SERVICE_${PN} = "lldpd.service"
50
51do_install_append() {
52 install -Dm 0755 ${WORKDIR}/lldpd.init.d ${D}${sysconfdir}/init.d/lldpd
53 install -Dm 0644 ${WORKDIR}/lldpd.default ${D}${sysconfdir}/default/lldpd
54 # Make an empty configuration file
55 touch ${D}${sysconfdir}/lldpd.conf
56}
57
58PACKAGES =+ "${PN}-zsh-completion"
59
60FILES_${PN} += "${libdir}/sysusers.d"
61RDEPENDS_${PN} += "os-release"
62
63FILES_${PN}-zsh-completion += "${datadir}/zsh/"
64# FIXME: zsh is broken in meta-oe so this cannot be enabled for now
65#RDEPENDS_${PN}-zsh-completion += "zsh"