blob: 42e883a310ec4cd487a6f5e6e3373470b7a8c5ae [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification"
2DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \
3middleware consistent with Service Availability Forum (SA Forum) \
4specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \
5established by leading Communications and Enterprise Computing Companies to \
6facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \
7code base in commercial products. \
8The OpenSAF project was launched in mid 2007 and has been under development by \
9an informal group of supporters of the OpenSAF initiative. The OpenSAF \
10Foundation was founded on January 22nd 2008 with Emerson Network Power, \
11Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
12HOMEPAGE = "http://www.opensaf.org"
13
14inherit autotools useradd systemd pkgconfig
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
17 file://install-samples-from-srcdir.patch \
18 file://0001-plmcd-error-fix.patch \
19 "
20
21SRC_URI[md5sum] = "82dd2777a672140e22b8205f10aa55d3"
22SRC_URI[sha256sum] = "da9e138650b835728ad51d99268d3a31419b254c4cb4e87c6ec90bc45266d7d2"
23
24SECTION = "admin"
25LICENSE = "LGPLv2.1"
26LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
27
28DEPENDS = "libxml2 python"
29
30USERADD_PACKAGES = "${PN}"
31GROUPADD_PARAM_${PN} = "-f -r opensaf"
32USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
33
34SYSTEMD_SERVICE_${PN} += "opensafd.service plmcboot.service plmcd.service"
35SYSTEMD_AUTO_ENABLE = "disable"
36
37PACKAGECONFIG[systemd] = "--enable-systemd-daemon"
38PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03 --enable-ais-plm,,openhpi"
39
40do_configure_prepend () {
41 ( cd ${S}; autoreconf -f -i -s )
42}
43
44EXTRA_OECONF += " --libdir=${libdir}/opensaf "
45EXTRA_OEMAKE += " -Wl,-rpath,${libdir}/opensaf "
46
47PKGLIBDIR="${libdir}/opensaf/opensaf"
48
49FILES_${PN} += "${localstatedir}/run"
50
51FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
52
53RDEPENDS_${PN} += "bash python"
54
55INSANE_SKIP_${PN} = "dev-so"
56
57do_install_append() {
58 rm -fr "${D}${localstatedir}/lock"
59 rm -fr "${D}${localstatedir}/run"
60 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
61 install -d ${D}${systemd_unitdir}/system
62 install -m 0644 ${B}/osaf/services/infrastructure/nid/config/opensafd.service \
63 ${D}${systemd_unitdir}/system
64 install -m 0644 ${B}/contrib/plmc/config/*.service ${D}/${systemd_unitdir}/system
65
66}