blob: f6aaee0eb60a005d799aae5f10e4a1dd9c2162a2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The PTP daemon (PTPd)"
2DESCRIPTION = "The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as \
3defined by the relevant IEEE 1588 standard. PTP Version 1 implements IEEE-1588-2002, \
4and PTP Version 2 implements IEEE-1588-2008. PTP was developed to provide very precise \
5time coordination of LAN connected computers."
6HOMEPAGE = "http://sourceforge.net/projects/ptpd"
7SECTION = "net"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://README;md5=0733e1b3788ab2ebbc63bf33a020da1d"
10
11DEPENDS = "libpcap"
12
13inherit autotools systemd
14
15# return something like '1.2.3' or '1.2.3/rc1'
16#
17def get_sub(d):
18 parts = d.getVar('PV',True).split('-')
19 try:
20 return parts[0] + '/' + parts[1]
21 except:
22 return parts[0]
23
24SRC_URI = "http://downloads.sourceforge.net/project/ptpd/ptpd/${@get_sub(d)}/ptpd-${PV}.tar.gz \
25 file://ptpd-use-pkgconfig.patch \
26 file://ptpd.service \
27 file://ptpd.conf \
28"
29
30SRC_URI[md5sum] = "253bab7ab51d969616ea811be1f132f3"
31SRC_URI[sha256sum] = "0dbf54dd2c178bd9fe62481d2c37513ee36636d8bf137cfdad96891490cdbf93"
32
33S = "${WORKDIR}/ptpd-${PV}"
34
35EXTRA_OEMAKE = ""
36
37EXTRA_OECONF += "--disable-snmp --with-pcap-config=pkg-config"
38
39do_install() {
40 install -d ${D}${bindir} ${D}${mandir}/man8
41 install -m 0755 ${B}/src/ptpd2 ${D}${bindir}
42 install -m 0644 ${B}/src/ptpd2.8 ${D}${mandir}/man8
43
44 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
45 install -d ${D}${systemd_unitdir}/system
46 install -m 0644 ${WORKDIR}/ptpd.service ${D}${systemd_unitdir}/system
47
48 sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/ptpd.service
49 sed -i -e 's#@BINDIR@#${bindir}#g' ${D}${systemd_unitdir}/system/ptpd.service
50
51 install -d ${D}${sysconfdir}/default/
52 install -m 0644 ${WORKDIR}/ptpd.conf ${D}${sysconfdir}/default/ptpd
53 fi
54}
55
56SYSTEMD_PACKAGES = "${PN}"
57SYSTEMD_SERVICE_${PN} = "ptpd.service"
58SYSTEMD_AUTO_ENABLE = "disable"