blob: 22aecbad2dc1ab1452154913e5c8f88cdc6018b4 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ZNC, an advanced IRC bouncer"
2SECTION = "net"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS = "openssl zlib icu"
7
8PV = "1.6.0"
9
10SRC_URI = "git://github.com/znc/znc.git;name=znc \
11 git://github.com/jimloco/Csocket.git;destsuffix=git/third_party/Csocket;name=Csocket \
12 "
13SRCREV_znc = "f47e8465efa4e1cd948b9caae93ac401b4355df8"
14SRCREV_Csocket = "07b4437396122650e5b8fb3d014e820a5decf4ee"
15
16# This constructs a composite revision based on multiple SRCREV's.
17#
18SRCREV_FORMAT = "znc_Csocket"
19
20S = "${WORKDIR}/git"
21
22inherit autotools-brokensep pkgconfig
23
24# ZNC has a custom autogen.sh that states that this command is needed *and* expected to fail
25do_configure_prepend() {
26 automake --add-missing || true
27}
28
29do_install_append() {
30 sed -i 's/-fdebug-prefix-map[^ ]*//g; s#${STAGING_DIR_TARGET}##g' ${D}${libdir}/pkgconfig/*.pc
31}