blob: d043b63898846fd64fe17d6473003712ae7e5e74 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "An L2TP client/server, designed for VPN use."
2DESCRIPTION = "OpenL2TP is an open source L2TP client / server, written \
3specifically for Linux. It has been designed for use as an enterprise \
4L2TP VPN server or in commercial, Linux-based, embedded networking \
5products and is able to support hundreds of sessions, each with \
6different configuration. It is used by several ISPs to provide \
7L2TP services and by corporations to implement L2TP VPNs."
8HOMEPAGE = "http://www.openl2tp.org/"
9SECTION = "net"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=e9d9259cbbf00945adc25a470c1d3585"
12DEPENDS = "popt flex readline"
13
14SRC_URI = "http://ftp.jaist.ac.jp/pub/sourceforge/o/op/${PN}/${PN}/${PV}/${BP}.tar.gz \
15 file://Makefile-modify-CFLAGS-to-aviod-build-error.patch \
16 file://openl2tp-simplify-gcc-warning-hack.patch \
17 "
18SRC_URI[md5sum] = "e3d08dedfb9e6a9a1e24f6766f6dadd0"
19SRC_URI[sha256sum] = "1c97704d4b963a87fbc0e741668d4530933991515ae9ab0dffd11b5444f4860f"
20
21inherit autotools-brokensep pkgconfig
22
23PARALLEL_MAKE = ""
24EXTRA_OEMAKE = 'CFLAGS="${CFLAGS} -Wno-nused-but-set-variable"'
25
26do_compile_prepend() {
27 sed -i -e "s:SYS_LIBDIR=.*:SYS_LIBDIR=${libdir}:g" \
28 -e 's:$(CROSS_COMPILE)as:${AS}:g' \
29 -e 's:$(CROSS_COMPILE)ld:${LD}:g' \
30 -e 's:$(CROSS_COMPILE)gcc:${CC}:g' \
31 -e 's:$(CROSS_COMPILE)ar:${AR}:g' \
32 -e 's:$(CROSS_COMPILE)nm:${NM}:g' \
33 -e 's:$(CROSS_COMPILE)strip:${STRIP}:g' \
34 -e 's:$(CROSS_COMPILE)install:install:g' \
35 ${S}/Makefile
36}