blob: 9307263c7ba6d5926a381ed345867e2cd7d4285b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "IPv4 link-local address allocator"
2DESCRIPTION = "Zeroconf is a program that is used to claim IPv4 \
3link-local addresses. IPv4 link-local addresses are useful when setting \
4up ad-hoc networking between devices without the involvement of a either \
5a DHCP server or network administrator. \
6These addresses are allocated from the 169.254.0.0/16 address range and \
7are normally attached to each Ethernet device in your computer. \
8Addresses are assigned randomly by each host and, in case of collision, \
9both hosts (are supposed to) renumber."
10AUTHOR = "Anand Kumria <wildfire@progsoc.uts.edu.au>"
11HOMEPAGE = "http://www.progsoc.org/~wildfire/zeroconf/"
12LICENSE = "GPLv2+"
13LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4 \
14 file://zeroconf.c;beginline=1;endline=13;md5=a5bada96e1e34b08eb7446b28e2630b2"
15SECTION = "net"
16
17PR = "r1"
18
19SRC_URI = "http://www.progsoc.org/~wildfire/zeroconf/download/${BPN}-${PV}.tar.gz \
20 file://compilefix.patch \
21 file://zeroconf-default \
22 file://debian-zeroconf"
23
24SRC_URI[md5sum] = "bdafb16b008ebb5633e4e581f77821d2"
25SRC_URI[sha256sum] = "a8c74df127753e2310fa1e072f3c9ca44a404bb0bbce9cfec7a84c6dff8bec7b"
26
27do_install () {
28 install -d ${D}${sbindir}
29 install -d ${D}${sysconfdir}/network/if-up.d
30 install -d ${D}${sysconfdir}/default
31 install -c -m 755 ${S}/zeroconf ${D}${sbindir}/zeroconf
32 install -c -m 755 ${WORKDIR}/debian-zeroconf ${D}${sysconfdir}/network/if-up.d/zeroconf
33 install -c ${WORKDIR}/zeroconf-default ${D}${sysconfdir}/default/zeroconf
34}