blob: be2ac665910aedd457c7ff5a344bf93cbf7910dc [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Administration tool for arp packet filtering"
2LICENSE = "GPL-2.0"
3SECTION = "net"
4
5PR = "r2"
6
7RDEPENDS_${PN} += "perl"
8
9LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
10SRC_URI = " \
11 ${SOURCEFORGE_MIRROR}/ebtables/arptables-v${PV}.tar.gz;name=arptables \
12 file://arptables-compile-install.patch \
13 file://arptables-init-busybox.patch \
14 file://arptables-arpt-get-target-fix.patch \
15 file://arptables-remove-bashism.patch \
16"
17SRC_URI[arptables.md5sum] = "1d4ab05761f063b0751645d8f2b8f8e5"
18SRC_URI[arptables.sha256sum] = "e529fd465c67d69ad335299a043516e6b38cdcd337a5ed21718413e96073f928"
19
20S = "${WORKDIR}/arptables-v${PV}"
21
22do_compile () {
23 oe_runmake
24}
25
26# the install target is not multi-job safe, but it doesn't do much
27# so we just install serially
28#
29PARALLEL_MAKEINST = "-j1"
30
31fakeroot do_install () {
32 oe_runmake 'BINDIR=${sbindir}' 'MANDIR=${mandir}/' 'DESTDIR=${D}' install
33}