blob: 87306a6f28016ec659df24d5c75d6c6db5974db0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "A a package of utilities for doing and managing mounts of the Linux CIFS filesystem."
2HOMEPAGE = "http://wiki.samba.org/index.php/LinuxCIFS_utils"
3SECTION = "otherosfs"
4LICENSE = "GPLv3 & LGPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = "samba"
8PV = "6.4"
9
10SRCREV = "487f46da737291877867cbd3acb40fea087d3863"
11SRC_URI = "git://git.samba.org/cifs-utils.git"
12
13S = "${WORKDIR}/git"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap"
17# when enabled, it creates ${bindir}/cifscreds and --ignore-fail-on-non-empty in do_install_append is needed
18PACKAGECONFIG[cifscreds] = "--enable-cifscreds,--disable-cifscreds,keyutils"
19# when enabled, it creates ${sbindir}/cifs.upcall and --ignore-fail-on-non-empty in do_install_append is needed
20PACKAGECONFIG[cifsupcall] = "--enable-cifsupcall,--disable-cifsupcall,krb5 libtalloc keyutils"
21PACKAGECONFIG[cifsidmap] = "--enable-cifsidmap,--disable-cifsidmap, keyutils"
22PACKAGECONFIG[pam] = "--enable-pam --with-pamdir=${base_libdir}/security,--disable-pam,libpam keyutils"
23
24inherit autotools pkgconfig
25
26do_install_append() {
27 # Remove empty /usr/bin and /usr/sbin directories since the mount helper
28 # is installed to /sbin
29 rmdir --ignore-fail-on-non-empty ${D}${bindir} ${D}${sbindir}
30}
31
32FILES_${PN} += "${base_libdir}/security"
33FILES_${PN}-dbg += "${base_libdir}/security/.debug"
34RRECOMMENDS_${PN} = "kernel-module-cifs"