blob: 5663f0e918feb0864d6a716a94b6702cc48fa724 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "C++ library for client-side URL transfers"
2HOMEPAGE = "http://code.google.com/p/curlpp/"
3SECTION = "libdevel"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
6
7DEPENDS = "curl boost"
8DEPENDS_class-native = "curl-native"
9
10SRC_URI = "http://curlpp.googlecode.com/files/curlpp-${PV}.tar.gz \
11 file://example21.cpp-remove-deprecated-code.patch \
12 "
13
14SRC_URI[md5sum] = "ccc3d30d4b3b5d2cdbed635898c29485"
15SRC_URI[sha256sum] = "e3f9427b27c5bddf898d383d45c0d3d5397e2056ff935d9a5cdaef6a9a653bd5"
16
17inherit autotools-brokensep pkgconfig binconfig
18
19PACKAGES =+ "libcurlpp libcurlpp-dev libcurlpp-staticdev"
20
21FILES_lib${BPN} = "${libdir}/lib*.so.* \
22 "
23
24FILES_lib${BPN}-dev = "${includedir} \
25 ${libdir}/lib*.la \
26 ${libdir}/pkgconfig \
27 ${bindir}/*-config"
28
29FILES_lib${BPN}-staticdev = "${libdir}/lib*.a"
30
31BBCLASSEXTEND = "native nativesdk"