blob: ca59bd21706de003b446a3d974380a27b0064d1f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "DNSSEC and DLV configuration and priming tool"
2DESCRIPTION = "\
3DNSSEC configuration and priming tool. Keys are required until the root \
4is signed, as well as for local unpublished DNSSEC keys to be preloaded \
5into the recursive nameserver. These DNSSEC configuration files can be \
6directly included in the bind or unbound nameserver configuration files. \
7dnssec-conf includes a commandline configuration client for Bind and \
8Unbound, known DNSSEC keys, URL's to official publication pages of keys, \
9and harvested keys, as well a script to harvest DNSKEY's from DNS. \
10See also: system-config-dnssec"
11HOMEPAGE = "https://github.com/xelerance/dnssec-conf"
12SECTION = "net"
13LICENSE = "GPLv2+"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=0636e73ff0215e8d672dc4c32c317bb3"
15DEPENDS += "xmlto-native docbook-xml-dtd4-native \
16 docbook-xsl-stylesheets-native libxslt-native"
17
18SRC_URI = "git://github.com/xelerance/dnssec-conf.git"
19SRCREV = "8e799683736b4a7b5e5e78f98fba0a6f48393537"
20
21S = "${WORKDIR}/git"
22
23do_install () {
24 rm -rf ${D}
25 make PREFIX=${prefix} DESTDIR=${D} ETCDIR=${D}${sysconfdir} install
26 # We no longer ship trust anchors. Most of these are in the DLV Registry now.
27 # and it prevents the problem of shipping outdated trust anchors.
28 # For DLV, we ship the ISC DLV Registry key
29 rm -rf ${D}${sysconfdir}/pki/dnssec-keys/harvest/*
30 rm -rf ${D}${sysconfdir}/pki/dnssec-keys/production/reverse/*
31 install -d -m 0755 ${D}${sysconfdir}/sysconfig
32 install -m 0644 packaging/fedora/dnssec.sysconfig ${D}${sysconfdir}/sysconfig/dnssec
33}
34
35RDEPENDS_${PN} = "python"