blob: 44459b529c6ccc219d59ece86eff663cda8bf78c [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD mirrors a block device over the network to another machine.\
3DRBD mirrors a block device over the network to another machine.\
4Think of it as networked raid 1. It is a building block for\
5setting up high availability (HA) clusters."
6HOMEPAGE = "http://www.drbd.org/"
7SECTION = "admin"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
10
11SRC_URI = "http://oss.linbit.com/drbd/${BP}.tar.gz \
12 file://0001-Makefile.in-don-t-compile-documentation.patch \
13 file://0001-Makefile.in-fix-permission-bits-for-drbd.service.patch \
14 "
15SRC_URI[md5sum] = "09c9c33c041e1f4f85dd359f9e0b0f24"
16SRC_URI[sha256sum] = "011050578c153bf4fef86e03749304ff9f333b7af3512c5c395e0e870a0445bd"
17
18SYSTEMD_SERVICE_${PN} = "drbd.service"
19SYSTEMD_AUTO_ENABLE = "disable"
20
21inherit autotools-brokensep systemd
22
23EXTRA_OECONF = " \
24 --with-initdir=/etc/init.d \
25 --without-pacemaker \
26 --without-rgmanager \
27 --without-bashcompletion \
28 --with-distro debian \
29 --with-initscripttype=both \
30 --with-systemdunitdir=${systemd_unitdir}/system \
31 "
32
33RDEPENDS_${PN} += "bash perl"
34
35# The drbd items are explicitly put under /lib when installed.
36#
37FILES_${PN} += "/run"
38FILES_${PN} += "${nonarch_base_libdir}/drbd \
39 ${nonarch_libdir}/drbd \
40 ${nonarch_libdir}/tmpfiles.d"
41FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"