blob: 163148cee3dbb47db24cff9040a87e31e4874ef7 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "User configurable send-only Mail Transfer Agent"
2DESCRIPTION = "ESMTP is a user-configurable relay-only MTA \
3with a sendmail-compatible syntax, based on libESMTP and \
4supporting the AUTH (including the CRAM-MD5 and NTLM SASL \
5mechanisms) and StartTLS SMTP extensions."
6HOMEPAGE = "http://esmtp.sourceforge.net/"
7SECTION = "net"
8
9DEPENDS = "libesmtp"
10
11LICENSE = "GPL-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.bz2"
15
16# Have to set this or we get -L/lib in LDFLAGS
17EXTRA_OECONF = "--with-libesmtp=${STAGING_EXECPREFIXDIR}"
18
19inherit autotools update-alternatives
20
21ALTERNATIVE_${PN} = "sendmail"
22
23ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
24ALTERNATIVE_TARGET[sendmail] = "${bindir}/esmtp"
25ALTERNATIVE_PRIORITY = "10"
26
27SRC_URI[md5sum] = "79a9c1f9023d53f35bb82bf446150a72"
28SRC_URI[sha256sum] = "a0d26931bf731f97514da266d079d8bc7d73c65b3499ed080576ab606b21c0ce"
29
30do_install_append() {
31 # only one file /usr/lib/sendmail in ${D}${libdir}
32 rm -rf ${D}${libdir}
33}
34
35pkg_postinst_${PN}_linuxstdbase () {
36 # /usr/lib/sendmial is required by LSB core test
37 [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/
38}
39
40FILES_${PN} += "${libdir}/"