blob: b6b17b70cee4021c7356698240e071a97adca444 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "sends ICMP ECHO_REQUEST packets to network hosts"
2DESCRIPTION = "fping is a ping like program which uses the Internet Control \
3Message Protocol (ICMP) echo request to determine if a target host is \
4responding. fping differs from ping in that you can specify any number of \
5targets on the command line, or specify a file containing the lists of \
6targets to ping. Instead of sending to one target until it times out or \
7replies, fping will send out a ping packet and move on to the next target \
8in a round-robin fashion."
9HOMEPAGE = "http://www.fping.org/"
10SECTION = "net"
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=09d77789fe32be35acde9637a5ee39b1"
13
14SRC_URI = "http://www.fping.org/dist/fping-${PV}.tar.gz"
15SRC_URI[md5sum] = "2e17cb655aa4eb59b5a4a38a89e746ed"
16SRC_URI[sha256sum] = "09b8960e235341bae6000085d38106357eae656a79e0119bd27e816c9003656a"
17
18S = "${WORKDIR}/fping-${PV}"
19
20inherit autotools
21
22EXTRA_OECONF = "--enable-ipv4"
23
24PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}"
25PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"