blob: 728ad5843da78a8772063ec09d4dea0ec60c6fa9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001#
2# Copyright (C) 2014, 2015 Wind River Systems, Inc.
3# Released under the MIT license (see COPYING.MIT for the terms)
4#
5SUMMARY = "GeoIP perl API library to access location database"
6DESCRIPTION = "perl library for country/city/organization to IP address or hostname mapping"
7HOMEPAGE = "http://www.maxmind.com/app/ip-location"
8SECTION = "libdevel"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10LIC_FILES_CHKSUM = "file://README;md5=b0fa745303912bd2d64430f7ae69487d"
11
12# Note that we do not want to use the upstream file name locally.
13#
14SRC_URI = "http://github.com/maxmind/geoip-api-perl/archive/v${PV}.tar.gz;downloadfilename=${BPN}-${PV}.tar.gz \
15 file://run-ptest \
16 "
17
18SRC_URI[md5sum] = "0ce57140890bf81958e0cea4fe1885b2"
19SRC_URI[sha256sum] = "c56437b1cc8887736cb1e435d0320c1c1ff3754830249516317b99137005fb23"
20
21S = "${WORKDIR}/geoip-api-perl-${PV}"
22
23DEPENDS += "geoip"
24
25inherit cpan ptest
26
27EXTRA_CPANFLAGS = "LIBS='-L${STAGING_LIBDIR}' INC='-I${STAGING_INCDIR}'"
28
29
30# perl scripts and some special small data files
31#
32do_install_ptest () {
33 install -d -m 0755 ${D}${PTEST_PATH}/t/data
34
35 install ${S}/t/*.t* ${D}${PTEST_PATH}/t
36 install ${S}/t/data/* ${D}${PTEST_PATH}/t/data
37}
38
39FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/Geo/IP/.debug"
40