blob: 7a3a002524b6c59379731578d7e7fc181770fb3a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Crontab entry to provide weekly updates of the GeoIP free databases."
2DESCRIPTION = "update databases for GeoIP"
3
4HOMEPAGE = "http://dev.maxmind.com/geoip/"
5SECTION = "net"
6
7DEPENDS = "zlib curl"
8
9SRC_URI = "https://github.com/maxmind/geoipupdate/releases/download/v2.2.1/geoipupdate-2.2.1.tar.gz \
10 file://GeoIP.conf \
11 file://geoipupdate.cron \
12 "
13
14SRC_URI[md5sum] = "abfd4bb9dd7fd489c103888dde5f2a57"
15SRC_URI[sha256sum] = "9547c42cc8620b2c3040fd8df95e8ee45c8b6ebcca7737d641f9526104d5f446"
16
17LICENSE = "GPLv2"
18
19LIC_FILES_CHKSUM = "\
20file://ChangeLog.md;md5=5ca3d911ed549b0756b03410ff77fa62 \
21"
22
23inherit autotools
24
25do_install_append() {
26 install -d ${D}/${sysconfdir}
27 install -d ${D}/${sysconfdir}/cron.d
28 install ${WORKDIR}/GeoIP.conf ${D}/${sysconfdir}/
29 install ${WORKDIR}/geoipupdate.cron ${D}/${sysconfdir}/cron.d/
30}