blob: 7302e9d3e4bc4afe4f6f3962fdba28e5dcd3001a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Linux Virtual Server administration Utility"
2DESCRIPTION = "Ipvsadm is used to set up, maintain or inspect the virtual server \
3table in the Linux kernel. The Linux Virtual Server can be used to \
4build scalable network services based on a cluster of two or more nodes. \
5The active node of the cluster redirects service requests to a \
6collection of server hosts that will actually perform the services. \
7Supported features include two protocols (TCP and UDP), three packet-forwarding \
8methods (NAT, tunneling, and direct routing), and eight load balancing algorithms \
9(round robin, weighted round robin, least-connec-tion, weighted least-connection, \
10locality-based least-connection, locality-based least-connection with replication, \
11destination-hashing, and source-hashing)."
12SECTION = "net"
13LICENSE = "GPL-2.0"
14LIC_FILES_CHKSUM = "file://README;beginline=40;endline=56;md5=a54cba37b64924aa5008881607942892"
15
16DEPENDS += "libnl popt"
17
18SRC_URI = "http://www.linuxvirtualserver.org/software/kernel-2.6/${BP}.tar.gz \
19 file://0001-Modify-the-Makefile-for-cross-compile.patch \
20 file://0002-Replace-nl_handle-to-nl_sock.patch \
21 file://0003-ipvsadm-remove-dependency-on-bash.patch \
22"
23
24SRC_URI[md5sum] = "eac3ba3f62cd4dea2da353aeddd353a8"
25SRC_URI[sha256sum] = "6d6c46fecb1c532a892616b4445c73b71730e8790d5630f60269fd9cbee0eb2d"
26
27do_compile() {
28 oe_runmake \
29 CC="${CC} -I${STAGING_INCDIR} -I${STAGING_INCDIR}/libnl3 -L${STAGING_LIBDIR}" \
30 all
31}
32
33do_install() {
34 oe_runmake 'BUILD_ROOT=${D}' install
35}