blob: d0ad748f595c7c1232a57161ffb139d7486008db [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "http://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPLv3+"
5
6DEPENDS += "libbsd libtalloc"
7RDEPENDS_python-tevent = "python"
8
9SRC_URI = "http://samba.org/ftp/tevent/tevent-${PV}.tar.gz"
10LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/LGPL-3.0;md5=bfccfe952269fff2b407dd11f2f3083b"
11
12SRC_URI[md5sum] = "945845817918f5cfbe0202d80a7db118"
13SRC_URI[sha256sum] = "04d953379025b1560af5c4ffcce58a3ee84db7aaa09c9f1e3eff5b2945a13529"
14
15inherit waf-samba
16
17PACKAGECONFIG[attr] = ",,attr"
18
19SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
20
21S = "${WORKDIR}/tevent-${PV}"
22
23EXTRA_OECONF += "--disable-rpath \
24 --bundled-libraries=NONE \
25 --builtin-libraries=replace \
26 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
27 --without-gettext \
28 "
29DISABLE_STATIC = ""
30
31PACKAGES += "python-tevent python-tevent-dbg"
32
33FILES_python-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
34FILES_python-tevent-dbg = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/.debug"