blob: 89a646f51934d92898df98d384d92514b3b5261f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require netcat.inc
2SUMMARY = "OpenBSD Netcat"
3HOMEPAGE = "http://ftp.debian.org"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://../debian/copyright;md5=ee6bbaacb5db5f2973818f0902c3ae6f"
6
7DEPENDS += "glib-2.0 libbsd"
8
9SRC_URI = "${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz;name=netcat \
10 ${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_${PV}-7.debian.tar.gz;name=netcat-patch"
11
12SRC_URI[netcat.md5sum] = "7e67b22f1ad41a1b7effbb59ff28fca1"
13SRC_URI[netcat.sha256sum] = "40653fe66c1516876b61b07e093d826e2a5463c5d994f1b7e6ce328f3edb211e"
14SRC_URI[netcat-patch.md5sum] = "e914f8eb7eda5c75c679dd77787ac76b"
15SRC_URI[netcat-patch.sha256sum] = "eee759327ffea293e81d0dde67921b7fcfcad279ffd7a2c9d037bbc8f882b363"
16
17S = "${WORKDIR}/${BPN}-${PV}"
18
19do_configure[noexec] = "1"
20
21netcat_do_patch() {
22 cd ${S}
23 quilt pop -a || true
24 QUILT_PATCHES=${WORKDIR}/debian/patches QUILT_SERIES=${WORKDIR}/debian/patches/series quilt push -a
25}
26
27python do_patch() {
28 bb.build.exec_func('netcat_do_patch', d)
29 bb.build.exec_func('patch_do_patch', d)
30}
31
32do_compile() {
33 cd ${S}
34 pkgrel=4
35 oe_runmake CFLAGS="$CFLAGS -DDEBIAN_VERSION=\"\\\"${pkgrel}\\\"\""
36}
37
38do_install() {
39 install -d ${D}${bindir}
40 install -m 755 ${S}/nc ${D}${bindir}/nc.${BPN}
41}
42ALTERNATIVE_PRIORITY = "50"