blob: 8c6837bac909889682c6b9a33486b596b93aa1fd [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# This package builds tools to manage NIS
2# The source package is utils/net/NIS/yp-tools
3#
4require nis.inc
5
6SUMMARY = "NIS client programs"
7DESCRIPTION = " \
8Network Information Service tools. \
9This package contains ypcat, ypmatch, ypset, \
10ypwhich, yppasswd, domainname, nisdomainname \
11and ypdomainname. \
12\
13This is the final IPv4-only version of yp-tools. \
14"
15
16SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2 \
17 file://domainname.service \
18"
19SRC_URI[md5sum] = "ba1f121c17e3ad65368be173b977cd13"
20SRC_URI[sha256sum] = "d01f70fadc643a55107a0edc47c6be99d0306bcc4f66df56f65e74238b0124c9"
21
22inherit systemd
23SYSTEMD_SERVICE_${PN} = "domainname.service"
24
25RPROVIDES_${PN} += "${PN}-systemd"
26RREPLACES_${PN} += "${PN}-systemd"
27RCONFLICTS_${PN} += "${PN}-systemd"
28
29CACHED_CONFIGUREVARS += "ac_cv_prog_STRIP=/bin/true"
30
31do_install_append() {
32 install -d ${D}${systemd_unitdir}/system
33 install -m 0644 ${WORKDIR}/domainname.service ${D}${systemd_unitdir}/system
34}