blob: b89f0b84aae65a505730493dcfce6020475d7aba [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# This package builds tools to manage NIS
2# The source package is utils/net/NIS/yp-tools
3#
4require nis.inc
5
6SUMMARY = "NIS client programs"
7DESCRIPTION = " \
8Network Information Service tools. \
9This package contains ypcat, ypmatch, ypset, \
10ypwhich, yppasswd, domainname, nisdomainname \
11and ypdomainname. \
12"
13
14PNBLACKLIST[yp-tools] ?= "BROKEN: fails to build for qemuarm."
15
16SRC_URI = "http://www.linux-nis.org/download/yp-tools/${BP}.tar.bz2 \
17 file://domainname.service \
18 file://yp-tools-ipv4-ipv6-Provide-an-in-place-version-of-mapv4v6addr.patch \
19"
20SRC_URI[md5sum] = "acebeecc11a73fb8097503670344834c"
21SRC_URI[sha256sum] = "812be817df3d4c25813552be336c6c6ad5aedaf65611b81af3ad9f98fb3c2e50"
22
23DEPENDS = "libtirpc"
24
25inherit autotools systemd
26SYSTEMD_SERVICE_${PN} = "domainname.service"
27
28RPROVIDES_${PN} += "${PN}-systemd"
29RREPLACES_${PN} += "${PN}-systemd"
30RCONFLICTS_${PN} += "${PN}-systemd"
31
32CACHED_CONFIGUREVARS += "ac_cv_prog_STRIP=/bin/true"
33
34EXTRA_OECONF = " \
35 --disable-rpath \
36 --libdir=${libdir}/yp-nis/ \
37 --includedir=${includedir}/yp-nis/ \
38 "
39
40FILES_${PN} += " ${libdir}/yp-nis/*.so.*.* ${libdir}/yp-nis/pkgconfig/"
41FILES_${PN}-dbg += " ${libdir}/yp-nis/.debug"
42FILES_${PN}-dev += " ${libdir}/yp-nis/*.so ${libdir}/yp-nis/*.so.[12] ${libdir}/yp-nis/*.la"
43FILES_${PN}-staticdev += " ${libdir}/yp-nis/*.a"
44
45do_install_append() {
46 install -d ${D}${systemd_unitdir}/system
47 install -m 0644 ${WORKDIR}/domainname.service ${D}${systemd_unitdir}/system
48}