blob: d113b82e89d0d7ce16a159d8610e87bfd70724d9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# This package builds the NIS ypbind daemon
2# The source package is utils/net/NIS/ypbind-mt
3#
4require nis.inc
5
6DESCRIPTION = " \
7Multithreaded NIS bind service (ypbind-mt). \
8ypbind-mt is a complete new implementation of a NIS \
9binding daemon for Linux. It has the following \
10features. Supports ypbind protocol V1 and V2. \
11Uses threads for better response. Supports multiple \
12domain bindings. Supports /var/yp/binding/* file \
13for Linux libc 4/5 and glibc 2.x. Supports a list \
14of known secure NIS server (/etc/yp.conf) Binds to \
15the server which answered as first. \
16\
17This is the final IPv4-only version of ypbind-mt. \
18"
19HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
20DEPENDS = " \
21 yp-tools \
22 ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
23 "
24RDEPENDS_${PN} += "yp-tools"
25
26# ypbind-mt now provides all the functionality of ypbind
27# and is used in place of it.
28PROVIDES += "ypbind"
29
30SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
31 file://ypbind.init \
32 file://ypbind.service \
33"
34SRC_URI[md5sum] = "094088c0e282fa7f3b3dd6cc51d0a4e1"
35SRC_URI[sha256sum] = "1930ce19f6ccfe10400f3497b31867f71690d2bcd3f5b575199fa915559b7746"
36
37inherit systemd update-rc.d
38
39SYSTEMD_SERVICE_${PN} = "ypbind.service"
40INITSCRIPT_NAME = "ypbind"
41INITSCRIPT_PARAMS = "start 44 3 5 . stop 70 0 1 2 6 ."
42
43CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
44
45do_install_append () {
46 install -d ${D}${sysconfdir}/init.d
47 install -d ${D}${sysconfdir}/rcS.d
48
49 install -m 0755 ${WORKDIR}/ypbind.init ${D}${sysconfdir}/init.d/ypbind
50
51 install -d ${D}${systemd_unitdir}/system
52 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
53}
54
55
56RPROVIDES_${PN} += "${PN}-systemd"
57RREPLACES_${PN} += "${PN}-systemd"
58RCONFLICTS_${PN} += "${PN}-systemd"