blob: cee5880f7a15d5d0da6f47e0cebd35241a52efa4 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# This package builds the NIS ypbind daemon
2# The source package is utils/net/NIS/ypbind-mt
3#
4require nis.inc
5
6DESCRIPTION = " \
7Multithreaded NIS bind service (ypbind-mt). \
8ypbind-mt is a complete new implementation of a NIS \
9binding daemon for Linux. It has the following \
10features. Supports ypbind protocol V1 and V2. \
11Uses threads for better response. Supports multiple \
12domain bindings. Supports /var/yp/binding/* file \
13for Linux libc 4/5 and glibc 2.x. Supports a list \
14of known secure NIS server (/etc/yp.conf) Binds to \
15the server which answered as first. \
16"
17HOMEPAGE = "http://www.linux-nis.org/nis/ypbind-mt/index.html"
18DEPENDS = "yp-tools ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
19PROVIDES += "ypbind"
20
21PNBLACKLIST[ypbind-mt] ?= "BROKEN: Depends on broken yp-tools"
22
23SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
24 file://ypbind.init \
25 file://ypbind.service \
26"
27SRC_URI[md5sum] = "54e2040d8266ae7d302d081ca310c8a8"
28SRC_URI[sha256sum] = "dc2f7d97c94dcab0acfdcd115cd8b464eb8c427e4bb0fe68404ae7465f517cd3"
29
30inherit systemd update-rc.d
31
32SYSTEMD_SERVICE_${PN} = "ypbind.service"
33INITSCRIPT_NAME = "ypbind"
34INITSCRIPT_PARAMS = "start 44 3 5 . stop 70 0 1 2 6 ."
35
36CACHED_CONFIGUREVARS = "ac_cv_prog_STRIP=/bin/true"
37
38EXTRA_OECONF = "PKG_CONFIG_PATH='${STAGING_LIBDIR}/yp-nis/pkgconfig/'"
39
40do_install_append () {
41 install -d ${D}${sysconfdir}/init.d
42 install -d ${D}${sysconfdir}/rcS.d
43
44 install -m 0755 ${WORKDIR}/ypbind.init ${D}${sysconfdir}/init.d/ypbind
45
46 install -d ${D}${systemd_unitdir}/system
47 install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
48}
49
50
51RPROVIDES_${PN} += "${PN}-systemd"
52RREPLACES_${PN} += "${PN}-systemd"
53RCONFLICTS_${PN} += "${PN}-systemd"