blob: a275238a3b340d139c00c57d58a044e0c09a50f8 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "network performance measurement tool"
5DESCRIPTION = "nuttcp is a network performance measurement tool intended for use by network \
6and system managers. Its most basic usage is to determine the raw TCP (or UDP) \
7network layer throughput by transferring memory buffers from a source system \
8across an interconnecting network to a destination system, either transferring \
9data for a specified time interval, or alternatively transferring a specified \
10number of bytes."
11HOMEPAGE = "http://www.nuttcp.net/Welcome%20Page.html"
12LICENSE = "GPL-2.0"
13SECTION = "net"
14LIC_FILES_CHKSUM = "file://${BP}.c;beginline=4;endline=30;md5=ae7045c3c3616092e07d87f04ba0d960"
15
16SRC_URI = "http://nuttcp.net/${BPN}/beta/${BP}.c"
17SRC_URI[md5sum] = "1ebf4a08bad2a295a8155f02995e8754"
18SRC_URI[sha256sum] = "c6e33810ccce67260f8d5d627f60e429d44f532365c58ed5673d035e2a59c4db"
19
20S = "${WORKDIR}"
21
22do_compile () {
23 ${CC} ${CFLAGS} -o nuttcp nuttcp-${PV}.c
24}
25
26do_install () {
27 install -d ${D}${bindir}
28 install -m 0755 nuttcp ${D}${bindir}
29}