blob: 7d1c5152b23432bec0d02688d26aed0799078df8 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Enhanced NetBSD ftp client"
2DESCRIPTION = "tnftp (formerly known as lukemftp) is a port of the NetBSD FTP client \
3to other systems. It offers many enhancements over the traditional \
4BSD FTP client, including command-line editing, command-line fetches \
5of FTP and HTTP URLs (including via proxies), command-line uploads of \
6FTP URLs, context-sensitive word completion, dynamic progress bar, \
7IPv6 support, modification time preservation, paging of local and \
8remote files, passive mode support (with fallback to active mode), \
9SOCKS support, TIS FWTK gate-ftp server support, and transfer rate \
10throttling."
11
12SECTION = "net"
13LICENSE = "BSD-4-Clause"
14
15DEPENDS = "ncurses"
16
17SRC_URI = "ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/${BPN}-${PV}.tar.gz \
18 file://tnftp-autotools.patch \
19 "
20
21inherit autotools update-alternatives pkgconfig
22
23ALTERNATIVE_PRIORITY = "100"
24
25ALTERNATIVE_${PN} = "ftp"
26ALTERNATIVE_LINK_NAME_${PN} = "${bindir}/ftp"
27ALTERNATIVE_TARGET_${PN} = "${bindir}/tnftp"
28
29FILES_${PN} = "${bindir}/tnftp"
30
31LIC_FILES_CHKSUM = "file://COPYING;md5=6d6796cb166a9bb050958241dad9479e"
32SRC_URI[md5sum] = "66e218d02ec7d9fc39ab70ba2900305a"
33SRC_URI[sha256sum] = "6f650e25f6fd51538f677b789b49379f367ae9f1dee74c94cfe24d92abc2cffb"
34
35PACKAGECONFIG ?= "openssl"
36PACKAGECONFIG[openssl] = "--enable-ssl, --disable-ssl --with-ssl=no, openssl"