blob: 09da1ef573064138707f854aef67b7b0dedd2fd0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A new modern implementation of traceroute(8) utility for Linux systems"
2DESCRIPTION = "The traceroute utility displays the route used by IP packets on \
3their way to a specified network (or Internet) host. Traceroute displays \
4the IP number and host name (if possible) of the machines along the \
5route taken by the packets. Traceroute is used as a network debugging \
6tool. If you're having network connectivity problems, traceroute will \
7show you where the trouble is coming from along the route."
8SECTION = "net"
9HOMEPAGE = "http://traceroute.sourceforge.net/"
10LICENSE = "GPL-2.0+ & LGPL-2.1+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
13
14inherit update-alternatives
15
16SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/${BP}/${BP}.tar.gz \
17 file://filter-out-the-patches-from-subdirs.patch \
18"
19
20SRC_URI[md5sum] = "79289adabd6f3ebf9160fc0815ab3150"
21SRC_URI[sha256sum] = "f7ac93ef30b13a587292b8d6a7e2538a65bc978a3a576eab238c392b884e96e0"
22
23EXTRA_OEMAKE = "VPATH=${STAGING_LIBDIR}"
24
25do_compile() {
26 export LDFLAGS="${TARGET_LDFLAGS} -L${S}/libsupp"
27 oe_runmake "env=yes"
28}
29
30do_install() {
31 install -d ${D}${bindir}
32 install -m755 ${BPN}/${BPN} ${D}${bindir}
33
34 install -m755 wrappers/tcptraceroute ${D}${bindir}
35
36 install -d ${D}${mandir}
37 install -p -m644 ${BPN}/${BPN}.8 ${D}${mandir}
38 ln -s ${BPN}.8 ${D}${mandir}/${BPN}6.8
39 ln -s ${BPN}.8 ${D}${mandir}/tcptraceroute.8
40
41}
42
43ALTERNATIVE_PRIORITY = "60"
44ALTERNATIVE_${PN} = "traceroute"
45ALTERNATIVE_LINK_NAME[traceroute] = "${bindir}/traceroute"