blob: d97ff0a5bdd272837a6f70e2750b20daaf8ea91c [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Analyze Suspend"
2DESCRIPTION = "analyze-suspend is a tool for system developers to visualize \
3the activity between suspend and resume, allowing them to identify \
4inefficiencies and bottlenecks."
5HOMEPAGE = "https://01.org/suspendresume"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9# Apart from the listed RDEPENDS, analyze-suspend depends on some features
10# provided by the kernel. These options are:
11# - CONFIG_PM_DEBUG=y
12# - CONFIG_PM_SLEEP_DEBUG=y
13# - CONFIG_FTRACE=y
14# - CONFIG_FUNCTION_TRACER=y
15# - CONFIG_FUNCTION_GRAPH_TRACER=y
16
17RDEPENDS_${PN} += "python-core python-datetime python-stringold"
18
19PV = "3.2+gitr${SRCPV}"
20SRCREV = "bce3cbec43bc2ce7a8c79b210314dd9d9ac1010b"
21SRC_URI = "git://github.com/01org/suspendresume.git;protocol=https"
22S = "${WORKDIR}/git"
23
24do_install() {
25 install -Dm 0755 analyze_suspend.py ${D}${bindir}/analyze_suspend.py
26 install -Dm 0644 README ${D}${docdir}/analyze-suspend/README
27}
28
29BBCLASSEXTEND = "native"