blob: e29921b52579380de3b943caed89be8b17b43202 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "OpenGL (ES) 2.0 benchmark"
2DESCRIPTION = "glmark2 is a benchmark for OpenGL (ES) 2.0. \
3It uses only the subset of the OpenGL 2.0 API that is compatible with OpenGL ES 2.0."
4HOMEPAGE = "https://launchpad.net/glmark2"
5BUGTRACKER = "https://bugs.launchpad.net/glmark2"
6
7LICENSE = "GPLv3+ & SGIv1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
9 file://COPYING.SGI;beginline=5;md5=269cdab4af6748677acce51d9aa13552"
10
11DEPENDS = "libpng12 jpeg"
12
13PV = "2014.03+${SRCPV}"
14
15SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
16 file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
17 file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch"
18SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a"
19
20S = "${WORKDIR}/git"
21
22inherit waf pkgconfig
23
24PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'x11-gl x11-gles2', '', d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland opengl', 'wayland-gl wayland-gles2', '', d)} \
26 drm-gl drm-gles2"
27
28PACKAGECONFIG[x11-gl] = ",,virtual/libgl virtual/libx11"
29PACKAGECONFIG[x11-gles2] = ",,virtual/libgles2 virtual/libx11"
30PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm"
31PACKAGECONFIG[drm-gles2] = ",,virtual/libgles2 libdrm"
32PACKAGECONFIG[wayland-gl] = ",,virtual/libgl wayland"
33PACKAGECONFIG[wayland-gles2] = ",,virtual/libgles2 wayland"
34
35python __anonymous() {
36 packageconfig = (d.getVar("PACKAGECONFIG", True) or "").split()
37 flavors = []
38 if "x11-gles2" in packageconfig:
39 flavors.append("x11-glesv2")
40 if "x11-gl" in packageconfig:
41 flavors.append("x11-gl")
42 if "wayland-gles2" in packageconfig:
43 flavors.append("wayland-glesv2")
44 if "wayland-gl" in packageconfig:
45 flavors.append("wayland-gl")
46 if "drm-gles2" in packageconfig:
47 flavors.append("drm-glesv2")
48 if "drm-gl" in packageconfig:
49 flavors.append("drm-gl")
50 if flavors:
51 d.appendVar("EXTRA_OECONF", " --with-flavors=%s" % ",".join(flavors))
52}