blob: 56272d9852ce479b426b226fa86814e90e3a8c36 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "BYTE Magazine's native benchmarks (also called BYTEmark) \
2designed to expose the capabilities of a system's CPU, FPU, \
3and memory system."
4HOMEPAGE = "http://www.tux.org/~mayer/linux/"
5LICENSE = "nbench-byte"
6LIC_FILES_CHKSUM = "file://README;beginline=57;endline=66;md5=020ef579f8fa5746b7e307a54707834f"
7SECTION = "console/utils"
8
9SRC_URI = "http://www.tux.org/~mayer/linux/${BP}.tar.gz \
10 file://nbench_32bits.patch \
11 file://Makefile-add-more-dependencies-to-pointer.h.patch"
12
13SRC_URI[md5sum] = "285dfab361080759d477ea1fe7d3093a"
14SRC_URI[sha256sum] = "723dd073f80e9969639eb577d2af4b540fc29716b6eafdac488d8f5aed9101ac"
15
16EXTRA_OEMAKE = "-e MAKEFLAGS="
17
18TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
19do_compile() {
20 oe_runmake
21}
22
23do_install () {
24 install -d ${D}${bindir}
25 install -m 0644 NNET.DAT ${D}${bindir}/
26 install -m 0755 nbench ${D}${bindir}/
27}