blob: 5acfbf1bb5503b4ccd34a6f7ebffcb05f41c0a42 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Phoronix Test Suite"
2DESCRIPTION = "The Phoronix Test Suite is designed to carry out both qualitative \
3and quantitative benchmarks in a clean, reproducible, and easy-to-use manner."
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6SECTION = "console/tests"
7
8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
9SRC_URI[md5sum] = "c3b26fcc57a3a253e558f759fdc1089f"
10SRC_URI[sha256sum] = "27add54f4ecb464549de580cece84b4a4945b99df3ef7ff7034eb7f23ffb3b39"
11S = "${WORKDIR}/phoronix-test-suite"
12
13inherit systemd allarch
14
15do_install() {
16 DESTDIR=${D} ./install-sh ${exec_prefix}
17
18 if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
19 install -d ${D}/${systemd_unitdir}/system/
20 mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
21 rm -rf ${D}/usr/lib/
22 fi
23}
24
25SYSTEMD_SERVICE_${PN} = "phoromatic-client.service phoromatic-server.service"
26RDEPENDS_${PN} += "bash python php-cli"
27
28FILES_${PN} += " \
29 ${datadir}/phoronix-test-suite \
30 ${datadir}/appdata/phoronix-test-suite.appdata.xml \
31 ${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
32 ${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
33 ${datadir}/mime/packages/openbenchmarking-mime.xml \
34 ${systemd_unitdir}/* \
35"