blob: 9898a70c2ce36e419899a2e5a6a10f9dfb244e5b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "A simple memory benchmark program, which tries to measure the \
2peak bandwidth of sequential memory accesses and the latency of random memory \
3accesses. Bandwidth is measured by running different assembly code for the \
4aligned memory blocks and attempting different prefetch strategies"
5HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345"
8
9PV = "0.3.9+git${SRCPV}"
10
11SRCREV = "95e68477588d41187b2d2e52ecf6be0e7eb06b8d"
12SRC_URI = "git://github.com/ssvb/tinymembench.git"
13
14S = "${WORKDIR}/git"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m755 tinymembench ${D}${bindir}/
19}
20
21# Fails to build with thumb-1 (qemuarm)
22#| {standard input}: Assembler messages:
23#| {standard input}:66: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
24#| {standard input}:69: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
25#| {standard input}:82: Error: selected processor does not support Thumb mode `mla r3,r4,r3,r5'
26#| {standard input}:82: Error: unshifted register required -- `and r8,r7,r3,lsr#16'
27ARM_INSTRUCTION_SET = "arm"