blob: 35af35fd3d869746678956be2581c2a7def06ebb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Threaded I/O tester"
2HOMEPAGE = "http://sourceforge.net/projects/tiobench/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
5
6PR = "r1"
7
8SRC_URI = "\
9 http://sourceforge.net/projects/tiobench/files/tiobench/${PV}/${BP}.tar.gz \
10 file://tiobench-makefile.patch \
11 file://avoid-glibc-clashes.patch \
12 file://0001-Drop-inline-of-crc32-function-to-fix-build-using-GCC.patch \
13"
14SRC_URI[md5sum] = "bf485bf820e693c79e6bd2a38702a128"
15SRC_URI[sha256sum] = "8ad011059a35ac70cdb5e3d3999ceee44a8e8e9078926844b0685b7ea9db2bcc"
16
17EXTRA_OEMAKE = "PREFIX=${D}/usr"
18
19do_install() {
20 oe_runmake install
21}
22
23RDEPENDS_${PN} = "\
24 perl \
25 perl-module-exporter-heavy \
26 perl-module-getopt-long \
27 perl-module-overload \
28 perl-module-strict \
29"