blob: 3a15d64cc866a7abb9232b0adfc410ec9864fb41 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Linux Bluetooth Stack HCI Debugger Tool"
2DESCRIPTION = "The hcidump tool reads raw HCI data coming from and going to a Bluetooth device \
3and displays the commands, events and data in a human-readable form."
4
5SECTION = "console"
6# hcidump was integrated into bluez5
7DEPENDS = "bluez4"
8RCONFLICTS_${PN} = "bluez5"
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
11 file://src/hcidump.c;beginline=1;endline=23;md5=3bee3a162dff43a5be7470710b99fbcf"
12PR = "r1"
13
14PNBLACKLIST[bluez-hcidump] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}"
15
16SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/bluez-hcidump-${PV}.tar.gz \
17 file://obsolete_automake_macros.patch \
18"
19
20SRC_URI[md5sum] = "2eab54bbd2b59a2ed4274ebb9390cf18"
21SRC_URI[sha256sum] = "9b7c52b375081883738cf049ecabc103b97d094b19c6544fb241267905d88881"
22S = "${WORKDIR}/bluez-hcidump-${PV}"
23
24inherit autotools