blob: d6d16c00fcf469614fc41423ea0c941813425855 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require bluez4.inc
2
3PNBLACKLIST[bluez4] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}"
4
5PR = "r11"
6
7SRC_URI += "file://bluetooth.conf \
8 file://sbc_mmx.patch \
9 file://fix-udev-paths.patch \
10 file://obsolete_automake_macros.patch \
11 file://network-fix-network-Connect-method-parameters.patch \
12 file://install-test-script.patch \
13 file://fix_encrypt_collision.patch \
14"
15
16SRC_URI[md5sum] = "fb42cb7038c380eb0e2fa208987c96ad"
17SRC_URI[sha256sum] = "59738410ade9f0e61a13c0f77d9aaffaafe49ba9418107e4ad75fe52846f7487"
18
19RCONFLICTS_${PN} = "bluez5"
20
21do_install_append() {
22 install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
23 install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
24 install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
25 # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
26 install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
27}
28
29RDEPENDS_${PN}-dev = "bluez-hcidump"
30RDEPENDS_${PN}-testtools += "python python-dbus python-pygobject"
31
32ALLOW_EMPTY_libasound-module-bluez = "1"
33PACKAGES =+ "libasound-module-bluez ${PN}-testtools"
34
35FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so ${datadir}/alsa"
36FILES_${PN} += "${libdir}/bluetooth/plugins ${libdir}/bluetooth/plugins/*.so ${base_libdir}/udev/ ${nonarch_base_libdir}/udev/ ${systemd_unitdir}/ ${datadir}/dbus-1"
37FILES_${PN}-dev += "\
38 ${libdir}/bluetooth/plugins/*.la \
39 ${libdir}/alsa-lib/*.la \
40"
41
42FILES_${PN}-testtools = "${libdir}/bluez4/test/*"
43
44FILES_${PN}-dbg += "\
45 ${libdir}/bluetooth/plugins/.debug \
46 ${libdir}/*/.debug \
47 */udev/.debug \
48"
49
50SYSTEMD_SERVICE_${PN} = "bluetooth.service"