blob: c38e20a723a536515af5e8ef0b40704ca9a43c0e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001HOMEPAGE = "http://w1.fi/hostapd/"
2SECTION = "kernel/userland"
3LICENSE = "GPLv2 | BSD"
4LIC_FILES_CHKSUM = "file://${B}/README;md5=4d53178f44d4b38418a4fa8de365e11c"
5DEPENDS = "libnl openssl"
6SUMMARY = "User space daemon for extended IEEE 802.11 management"
7
8inherit update-rc.d systemd
9INITSCRIPT_NAME = "hostapd"
10
11SYSTEMD_SERVICE_${PN} = "hostapd.service"
12SYSTEMD_AUTO_ENABLE_${PN} = "disable"
13
14SRC_URI = " \
15 http://w1.fi/releases/hostapd-${PV}.tar.gz \
16 file://defconfig \
17 file://init \
18 file://hostapd.service \
19"
20
21S = "${WORKDIR}/hostapd-${PV}"
22B = "${WORKDIR}/hostapd-${PV}/hostapd"
23
24do_configure() {
25 install -m 0644 ${WORKDIR}/defconfig ${B}/.config
26}
27
28do_compile() {
29 export CFLAGS="-MMD -O2 -Wall -g -I${STAGING_INCDIR}/libnl3"
30 make
31}
32
33do_install() {
34 install -d ${D}${sbindir} ${D}${sysconfdir}/init.d ${D}${systemd_unitdir}/system/
35 install -m 0644 ${B}/hostapd.conf ${D}${sysconfdir}
36 install -m 0755 ${B}/hostapd ${D}${sbindir}
37 install -m 0755 ${B}/hostapd_cli ${D}${sbindir}
38 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
39 install -m 0644 ${WORKDIR}/hostapd.service ${D}${systemd_unitdir}/system/
40 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/hostapd.service
41}
42
43CONFFILES_${PN} += "${sysconfdir}/hostapd.conf"
44
45SRC_URI[md5sum] = "69f9cec3f76d74f402864a43e4f8624f"
46SRC_URI[sha256sum] = "8e272d954dc0d7026c264b79b15389ec2b2c555b32970de39f506b9f463ec74a"