blob: 254b855f3d5b408d991593e983d3fb4f7f23e6da [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "Precision Time Protocol (PTP) according to IEEE standard 1588 for Linux"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "http://sourceforge.net/projects/linuxptp/files/v${PV}/linuxptp-${PV}.tgz \
6 file://build-Allow-CC-and-prefix-to-be-overriden.patch"
7
8SRC_URI[md5sum] = "6aa15d83f5a35f1fd076ba9adc4e7285"
9SRC_URI[sha256sum] = "e7fd16a9f235b059be527bd512e86f0c1d9f2e7c36736e6d6d9727a4427ac14c"
10
11EXTRA_OEMAKE = "ARCH=${TARGET_ARCH} \
12 EXTRA_CFLAGS='-D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_ONESTEP_SYNC ${CFLAGS}'"
13
14do_install () {
15 install -d ${D}/${bindir}
16 install -p ${S}/ptp4l ${D}/${bindir}
17 install -p ${S}/pmc ${D}/${bindir}
18 install -p ${S}/phc2sys ${D}/${bindir}
19 install -p ${S}/hwstamp_ctl ${D}/${bindir}
20}