blob: a173e696abb2982ba6fea317f0158a4313643bca [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit gnomebase gettext systemd vala gobject-introspection
11
12DEPENDS = "glib-2.0 libgudev dbus-glib"
13
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz"
15SRC_URI[md5sum] = "66cc7266b15525cb366253e6639fc564"
16SRC_URI[sha256sum] = "7ef5035375a953b285a742591df0a65fd442f4641ce4d8f4392a41d6d6bc70b3"
17
18S = "${WORKDIR}/ModemManager-${PV}"
19
20PACKAGECONFIG ??= "mbim qmi polkit \
21 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
22"
23
24PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,"
25PACKAGECONFIG[polkit] = "--with-polkit=yes,--with-polkit=no,polkit"
26# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
27PACKAGECONFIG[mbim] = "--with-mbim,--enable-mbim=no,libmbim"
28# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
29PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi"
30
31FILES_${PN} += " \
32 ${datadir}/icons \
33 ${datadir}/polkit-1 \
34 ${datadir}/dbus-1 \
35 ${libdir}/ModemManager \
36 ${systemd_unitdir}/system \
37"
38
39FILES_${PN}-dev += " \
40 ${libdir}/ModemManager/*.la \
41"
42
43FILES_${PN}-staticdev += " \
44 ${libdir}/ModemManager/*.a \
45"
46
47FILES_${PN}-dbg += "${libdir}/ModemManager/.debug"
48
49SYSTEMD_SERVICE_${PN} = "ModemManager.service"