blob: 6ac7905989f89417201bc75a9e479a0031e23268 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "The Openobex project is an open source implementation of the \
2Object Exchange (OBEX) protocol."
3HOMEPAGE = "http://openobex.triq.net"
4SECTION = "libs"
5DEPENDS = "virtual/libusb0"
6DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}"
7
8LICENSE = "GPLv2 & LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
10 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
11"
12
13SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/openobex-${PV}.tar.gz \
14 file://disable-cable-test.patch \
15 file://libusb_crosscompile_check.patch \
16 file://separate_builddir.patch"
17
18SRC_URI[md5sum] = "0d83dc86445a46a1b9750107ba7ab65c"
19SRC_URI[sha256sum] = "e602047570799a47ecb028420bda8f2cef41310e5a99d084de10aa9422935e65"
20
21inherit autotools binconfig pkgconfig
22
23EXTRA_OECONF = "--enable-apps --enable-syslog"
24
25do_install_append() {
26 install -d ${D}${datadir}/aclocal
27 install -m 0644 ${S}/openobex.m4 ${D}${datadir}/aclocal
28}
29
30PACKAGES += "openobex-apps"
31FILES_${PN} = "${libdir}/lib*.so.*"
32FILES_${PN}-dev += "${bindir}/openobex-config"
33FILES_${PN}-apps = "${bindir}/*"
34DEBIAN_NOAUTONAME_${PN}-apps = "1"
35