blob: 3e644760ceecbf52be4b011a5554c7a523733bcb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Radio enable/disable command line utility"
2HOMEPAGE = "http://linuxwireless.org/en/users/Documentation/rfkill"
3SECTION = "base"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c6036d0eb7edbfced28c4160e5d3fa94"
6
7SRC_URI = "http://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.bz2 \
8 file://0001-rfkill-makefile-don-t-use-t-the-OE-install-wrapper-d.patch \
9 file://dont.call.git.rev-parse.on.parent.dir.patch"
10
11SRC_URI[md5sum] = "b957713a6cfbcd8ac0e94420aeddcf1a"
12SRC_URI[sha256sum] = "3e160cca504a53679f2b3254f31c53a4fb38a021bc50fed8eb57a436d33dfa07"
13
14do_compile() {
15 oe_runmake
16}
17
18do_install() {
19 oe_runmake DESTDIR=${D} install
20}
21
22inherit update-alternatives
23
24ALTERNATIVE_${PN} = "rfkill"
25ALTERNATIVE_PRIORITY = "60"
26ALTERNATIVE_LINK_NAME[rfkill] = "${sbindir}/rfkill"
27