blob: 95adecdf9672f828efc432edda8bf955bc9c8b75 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "SMS Gateway software"
2DESCRIPTION = "The SMS Server Tools 3 is a SMS Gateway software which can send and receive short messages through GSM modems and mobile phones."
3SECTION = "console/network"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4d21efa1bb2a186360dde4035f860682"
6HOMEPAGE = "http://smstools3.kekekasvi.com"
7
8SRC_URI = "http://smstools3.kekekasvi.com/packages/${BP}.tar.gz \
9 file://sms_binpath_and_psops.patch \
10 file://fix-makefile-override.patch"
11
12SRC_URI[md5sum] = "0241ef60e646fac1a06254a848e61ed7"
13SRC_URI[sha256sum] = "ed00ffaeaa312a5b4f969f4e97a64603a866bbe16e393ea02f5bf05234814d59"
14
15
16S = "${WORKDIR}/${BPN}"
17
18RDEPENDS_${PN} = "bash"
19INITSCRIPT_NAME = "sms3"
20INITSCRIPT_PARAMS = "defaults"
21
22inherit update-rc.d
23
24do_install () {
25
26 install -d ${D}${bindir}
27 install -m 755 ${S}/src/smsd "${D}${bindir}/smsd"
28
29 install -m 755 ${S}/scripts/sendsms "${D}${bindir}/sendsms"
30 install -m 755 ${S}/scripts/sms2html "${D}${bindir}/sms2html"
31 install -m 755 ${S}/scripts/sms2unicode "${D}${bindir}/sms2unicode"
32 install -m 755 ${S}/scripts/unicode2sms "${D}${bindir}/unicode2sms"
33
34 install -d ${D}${sysconfdir}
35 install -m 644 ${S}/examples/smsd.conf.easy "${D}${sysconfdir}/smsd.conf"
36
37 install -d "${D}${localstatedir}/spool"
38 install -d "${D}${localstatedir}/spool/sms"
39 install -d "${D}${localstatedir}/spool/sms/incoming"
40 install -d "${D}${localstatedir}/spool/sms/outgoing"
41 install -d "${D}${localstatedir}/spool/sms/checked"
42
43 install -d ${D}${sysconfdir}/init.d
44 install -m 755 ${S}/scripts/sms3 "${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}"
45
46}