blob: 52bf811e348b0c13be846a52424e07d217fcee8a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "This daemon is in charge of multiplexing connections over USB to an iPhone or iPod touch."
2LICENSE = "GPLv3 & GPLv2 & LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=ebb5c50ab7cab4baeffba14977030c07 \
4 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
5 file://COPYING.LGPLv2.1;md5=6ab17b41640564434dda85c06b7124f7"
6
7DEPENDS = "udev libusb1"
8
9inherit cmake pkgconfig gitpkgv
10
11PKGV = "${GITPKGVTAG}"
12
13SRCREV = "919587580c5e77f3936f3432115d2e10c7bac7c5"
14SRC_URI = "git://git.sukimashita.com/usbmuxd.git;protocol=http"
15
16S = "${WORKDIR}/git"
17
18FILES_${PN} += "${base_libdir}/udev/rules.d/"
19
20# fix usbmuxd installing files to /usr/lib64 on 64bit hosts:
21EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
22
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[plist] = "-DWANT_PLIST=1,-DWANT_PLIST=0,libplist"