blob: 2b6f56ed4fc933104646d1906e8a2acdc87ea9c0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "The Internet Communications Engine"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://ICE_LICENSE;md5=3dc3037023cc2ae6b2c5b995da529515"
4DEPENDS = "bzip2 expat openssl python db mcpp"
5DEPENDS_prepend_class-target = "zeroc-ice-native "
6
7SRC_URI = "http://www.zeroc.com/download/Ice/3.5/Ice-${PV}.tar.gz \
8 file://0002-Modify-Makefile-for-cross-compile.patch \
9 "
10SRC_URI[md5sum] = "f00c59983cc904bca977133c0a9b3e80"
11SRC_URI[sha256sum] = "989e51194c6adadbd156da3288e37bad847b93b3b876502e83033b70493af392"
12
13#| MapDb.cpp: In constructor 'Freeze::MapDb::MapDb(const ConnectionIPtr&, const string&, const string&, const string&, const KeyCompareBasePtr&, const std::vector<IceUtil::Handle<Freeze::MapIndexBase> >&, bool)':
14#| MapDb.cpp:138:46: error: call of overloaded 'set_bt_compare(int (*)(DB*, const DBT*, const DBT*))' is ambiguous
15#| MapDb.cpp:138:46: note: candidates are:
16#| /home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/include/db_cxx.h:272:14: note: virtual int Db::set_bt_compare(bt_compare_fcn_type) <near match>
17#| /home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/include/db_cxx.h:272:14: note: no known conversion for argument 1 from 'int (*)(DB*, const DBT*, const DBT*) {aka int (*)(__db*, const __db_dbt*, const __db_dbt*)}' to 'bt_compare_fcn_type {aka int (*)(__db*, const __db_dbt*, const __db_dbt*, long unsigned int*)}'
18#| /home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/include/db_cxx.h:273:14: note: virtual int Db::set_bt_compare(int (*)(Db*, const Dbt*, const Dbt*, size_t*)) <near match>
19#| /home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/include/db_cxx.h:273:14: note: no known conversion for argument 1 from 'int (*)(DB*, const DBT*, const DBT*) {aka int (*)(__db*, const __db_dbt*, const __db_dbt*)}' to 'int (*)(Db*, const Dbt*, const Dbt*, size_t*) {aka int (*)(Db*, const Dbt*, const Dbt*, long unsigned int*)}'
20#| make[3]: *** [MapDb.o] Error 1
21PNBLACKLIST[zeroc-ice] ?= "BROKEN: not compatible with default db version"
22
23S = "${WORKDIR}/Ice-${PV}"
24
25inherit python-dir pkgconfig
26
27export PYTHON_VERSION = "python2.7"
28
29do_configure() {
30 :
31}
32
33do_compile_prepend_class-target () {
34 export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}"
35 export PYTHON_LIB_DIR="${STAGING_LIBDIR}/${PYTHON_DIR}"
36 export ICE_HOME="${STAGING_DIR_NATIVE}/usr"
37}
38
39do_compile_prepend_class-nativesdk () {
40 export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}"
41 export PYTHON_LIB_DIR="${STAGING_LIBDIR}/${PYTHON_DIR}"
42 export ICE_HOME="${STAGING_DIR_NATIVE}/usr"
43}
44
45do_compile_prepend_class-native () {
46 export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}"
47 export PYTHON_LIB_DIR="${STAGING_LIBDIR}/${PYTHON_DIR}"
48 export ICE_HOME="${S}/cpp"
49}
50
51do_compile() {
52 oe_runmake -C ${S} cpp
53 oe_runmake -C ${S} py
54}
55
56do_install_prepend_class-target () {
57 export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}"
58 export PYTHON_LIB_DIR="${STAGING_LIBDIR}/${PYTHON_DIR}"
59 export ICE_HOME="${STAGING_DIR_NATIVE}/usr"
60}
61
62do_install_prepend_class-nativesdk () {
63 export PYTHON_INCLUDE_DIR="${STAGING_INCDIR}/${PYTHON_DIR}"
64 export PYTHON_LIB_DIR="${STAGING_LIBDIR}/${PYTHON_DIR}"
65 export ICE_HOME="${STAGING_DIR_NATIVE}/usr"
66}
67
68do_install_prepend_class-native () {
69 export ICE_HOME="${S}/cpp"
70}
71
72do_install() {
73 oe_runmake -C ${S}/cpp prefix=${D}${prefix} install install-common
74 oe_runmake -C ${S}/py prefix=${D}${prefix} install
75}
76
77PACKAGES += "${PN}-python ${PN}-python-dev ${PN}-python-dbg"
78
79FILES_${PN}-doc += "${prefix}/man/man1"
80FILES_${PN} += "${prefix}/*LICENSE ${libdir}/ImportKey.class ${prefix}/RELEASE_NOTES ${prefix}/CHANGES"
81FILES_${PN}-dev += "${includedir} ${prefix}/slice ${prefix}/config"
82FILES_${PN}-python-dev = "${PYTHON_SITEPACKAGES_DIR}/IcePy.so"
83FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*.py ${PYTHON_SITEPACKAGES_DIR}/IcePy.so.* ${PYTHON_SITEPACKAGES_DIR}/Ice*/*.py"
84FILES_${PN}-python-dbg = "${PYTHON_SITEPACKAGES_DIR}/.debug"
85FILES_${PN}-dev += "${bindir}/slice* ${datadir}/Ice-${PV}/slice/*"
86
87BBCLASSEXTEND = "native nativesdk"