blob: 37b3c18705752b7ca6958b4f5f3b6f8931a8014c [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Gives a fake root environment"
2HOMEPAGE = "http://fakeroot.alioth.debian.org"
3SECTION = "base"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
6
7SRC_URI = "\
8 ${DEBIAN_MIRROR}/main/f/fakeroot/fakeroot_${PV}.orig.tar.bz2 \
9"
10
11inherit autotools
12
13do_configure_prepend() {
14 mkdir -p ${S}/build-aux
15}
16
17do_install_append() {
18 install -d ${D}${includedir}/fakeroot
19 install -m 644 *.h ${D}${includedir}/fakeroot
20}
21
22# fakeroot needs getopt which is provided by the util-linux package
23RDEPENDS_${PN} = "util-linux"
24
25
26SRC_URI[md5sum] = "706171d8d520b1ca1576ac73f2ceb4f3"
27SRC_URI[sha256sum] = "0a359efa3e9496c33234b3e9c89306a09bb4da9d33de43c261f1d8447e6ebea2"
28
29# http://errors.yoctoproject.org/Errors/Details/35143/
30PNBLACKLIST[fakeroot] ?= "BROKEN: QA Issue: -dev package contains non-symlink .so"